IsHatchPatternReference

Verifies that a hatch pattern is from a reference file.

Syntax

Rhino.IsHatchPatternReference (strHatch)

Parameters

strHatch

Required.  String.  The name of an existing hatch pattern.

Returns

True

If successful.

False

If not successful.

Null

On error.

Example

Dim strHatch

strHatch = Rhino.GetString("Hatch pattern name")

If Rhino.IsHatchPattern(strHatch) Then

If Rhino.IsHatchPatternReference(strHatch) Then

Rhino.Print "The hatch pattern is reference."

Else

Rhino.Print "The hatch pattern is not reference."

End If

Else

Rhino.Print "The hatch pattern does not exist."

End If

Also See

IsHatchPattern

IsHatchPatternCurrent