Home > Introduction
Microsoft Windows Script is a comprehensive scripting infrastructure for the Windows platform. Windows Script provides script engines, such as Visual Basic Scripting Edition, which can be embedded into Windows applications and an extensive array of supporting technologies that make it easier for users to script Windows applications.
Visual Basic Scripting Edition, also known as VBScript, enables authors to create scripts using a subset of the Microsoft Visual Basic language. If you are already a Visual Basic programmer, or if you are not a programmer but are looking for a scripting language that is easy to learn, VBScript might be the right language for you. VBScript is implemented as a fast, portable interpreter for use in Web browsers and applications that use ActiveX controls and OLE Automation servers.
VBScript is a strict subset of the Visual Basic for Applications language that is used in popular applications such as Microsoft Excel, Microsoft Access, Microsoft Project, and the Visual Basic development system. VBScript was designed to be fast, so it does not support the use of strict types - it only supports the use of Variants. It also must be safe for the World Wide Web, so it does not include functionality that directly accesses the client machine's operating system or file system. For example, you cannot do file I/O or read the registry on the client machine.
RhinoScript is a plug-in for Rhinoceros that implements Windows Script. In addition to providing support for VBScript, RhinoScript also runs as an OLE Automation server that exposes the internal workings of Rhino to automation.
The information in this help file pertains to the usage of the RhinoScript plug-in and the methods contained in the RhinoScript Automation object. Additional support for RhinoScript can be obtained from the following resources.
Scripting category on Discourse
RhinoScript samples repository on GitHub
The following online resources can help you get started with and learn more about RhinoScript.
Essential Mathematics for Computational Design