LayerLinetype

Returns or changes the linetype of a layer.

Syntax

Rhino.LayerLinetype (strLayer [, strLinetype])

Parameters

strLayer

Required. String. The name or identifier of an existing layer.

strLinetype

Optional. String. The name of the new linetype.

Returns

String

If a linetype is not specified,  the name of the current linetype if successful.

String

If a linetype is specified, the name of the previous linetype if successful.

Null

If not successful, or on error.

Example

Dim arrLayers, strLayer

arrLayers = Rhino.LayerNames

If IsArray(arrLayers) Then

  For Each strLayer In arrLayers

    If Rhino.LayerLinetype(strLayer) <> "Continuous" Then

      Rhino.LayerLinetype strLayer, "Continuous"

    End If

  Next

End If

Also See

LayerPrintColor

LayerPrintWidth