LayerPrintWidth

Returns or changes the print width of a layer. Print width is specified in millimeters. A print width of 0.0 denotes the "default" print width. A print width < 0.0 will set the layer to "No Print".

Syntax

Rhino.LayerPrintWidth (strLayer [, dblWidth])

Parameters

strLayer

Required. String. The name or identifier of an existing layer.

dblWidth

Optional. Number. The new layer print width in millimeters.

Returns

Number

If a layer print width is not specified,  the current layer print width if successful.

Number

If a layer print width is specified, the previous layer print width if successful.

Null

If not successful, or on error.

Example

Dim arrLayers, strLayer

arrLayers = Rhino.LayerNames

If IsArray(arrLayers) Then

  For Each strLayer In arrLayers

    If Rhino.LayerPrintWidth(strLayer) <> 0.0 Then

      Rhino.LayerPrintWidth strLayer, 0.0

    End If

  Next

End If

Also See

LayerLinetype

LayerPrintColor