Returns or changes the radius of a spot light.
Rhino.SpotLightRadius (strObject [, dblRadius])
strObject |
Required. String. The light object's identifier. |
dblRadius |
Optional. Number. The new radius value. If omitted, the current radius value is returned. |
Number |
If dblRadius is not specified, then the current radius value if successful. |
Number |
If dblRadius is specified, then the previous radius value if successful. |
Null |
If not successful, or on error. |
Const rhObjectLight = 256
Dim strObject
strObject = Rhino.GetObject("Select a light", rhObjectLight)
If Not IsNull(strObject) Then
Rhino.SpotLightRadius strObject, 5.0
End If