The following methods are available for creating, querying or manipulating light objects.
Method |
Description |
Adds a directional light. |
|
Adds a linear light. |
|
Adds a point light. |
|
Adds a rectangular light. |
|
Adds a spot light. |
|
Returns or sets the enabled status of a light. |
|
Verifies a light is a directional light. |
|
Verifies an object is a light. |
|
Verifies a light is enabled. |
|
Verifies a light is referenced from another file. |
|
Verifies a light is a linear light. |
|
Verifies a light is a point light. |
|
Verifies a light is a rectangular light. |
|
Verifies a light is a spot light. |
|
Returns or sets a light's diffuse color. |
|
Returns the number of lights in the document. |
|
Returns or sets the direction of a light object. |
|
Returns or sets the location of a light object. |
|
Returns or sets the name of a light object. |
|
Returns the identifiers of all lights in the document. |
|
Returns the plane of a rectangular light. |
|
Returns or modifies the hardness of a spot light. |
|
Returns or modifies the radius of a spot light. |
|
Returns or modifies the shadow intensity of a spot light. |