Returns the distance from a 3-D point to a plane.
Rhino.DistanceToPlane (arrPlane, arrPoint)
arrPlane |
Required. Array. The plane. The elements of a plane array are as follows:
|
||||||||||
arrPoint |
Required. Array. The 3-D point. |
Number |
The distance if successful. |
Null |
If not successful, or on error. |
Dim arrPlane, arrPoint, dblDistance
arrPoint = Rhino.GetPoint("Point to test")
If IsArray(arrPoint) Then
arrPlane = Rhino.ViewCPlane
If IsArray(arrPlane) Then
dblDistance = Rhino.DistanceToPlane(arrPlane, arrPoint)
If Not IsNull(dblDistance) Then
Rhino.Print "Distance to plane: " & CStr(dblDistance)
End If
End If
End If