The following methods are available for creating and manipulating lines and planes.
Lines are represented as zero-based, one-dimensional arrays containing two elements: the start point (3-D point) and the end point (3-D point).
Planes are represented as zero-based, one-dimensional arrays containing four elements: the plane's origin (3-D point), the plane's x-axis direction (3-D vector), the plane's y-axis direction (3-D vector), and the plane's z-axis direction (3-D vector).
For more information, see RhinoScript Fundamentals.
Method |
Description |
Intersects two coplanar circles. |
|
Returns the distance from a plane to a point. |
|
Evaluates a point on a plane. |
|
Returns the point calculated by intersecting three planes. |
|
Intersects an infinite line and an arc. |
|
Create a line perpendicular or tangent between two curves. |
|
Intersects an infinite line and an axis aligned bounding box. |
|
Intersects an infinite line and a circle. |
|
Finds the point on an infinite line that is closest to a test point. |
|
Intersect an infinite line and a curve object. |
|
Calculates the intersection of a line and a cylinder. |
|
Determines if the shortest distance from a line to a point or another line is greater than a specified distance. |
|
Returns the point calculated by intersecting two lines. |
|
Finds the longest distance between the line, as a finite chord, and a point or another line. |
|
Intersects an infinite line with a mesh object. |
|
Finds the shortest distance between the line, as a finite chord, and a point or another line. |
|
Returns a plane that contains the line. |
|
Returns the point calculated by intersecting a line with a plane. |
|
Calculates the intersection of a line and a sphere. |
|
Transforms a line. |
|
Moves the origin of a plane. |
|
Calculates the angle between two points on a plane. |
|
Intersects a plane and an arc. |
|
Intersects a plane and a circle. |
|
Returns the closest point on a plane from a point. |
|
Intersects an infinite plane and a curve object. |
|
Returns the equation of a plane. |
|
Returns a plane through an array of points. |
|
Creates a plane from an origin point, X axis direction, and Y axis direction. |
|
Creates a plane from an origin point, and a normal direction. |
|
Creates a plane from three non-colinear points. |
|
Returns the line calculated by intersecting two planes. |
|
Calculates the intersection of a plane and a sphere. |
|
Transforms a plane. |
|
Rotates a plane. |
|
Returns Rhino's world XY plane. |
|
Returns Rhino's world YZ plane. |
|
Returns Rhino's world ZX plane. |