LineCircleIntersection

Intersect an infinite line and a circle.

Syntax

Rhino.LineCircleIntersection (arrLine, arrPlane, dblRadius)

Parameters

arrLine

Required.  Array.  Two 3-D points identifying the starting and ending points of the line.

arrPlane

Required.  Array.  The plane of the circle. The origin of the plane is the center point of the circle.

dblRadius

Required.  Number.  The radius of the circle.

Returns

Array

An array containing the 3-D intersection points if successful.

Null

If not successful, or on error.

Example

Dim arrLine

arrLine = Array(Array(0,0,0), Array(2,1,0))

arrPoints = Rhino.LineCircleIntersection(arrLine, Rhino.WorldXYPlane, 5.0)

If IsArray(arrPoints) Then

  Rhino.AddPoints arrPoints

End If

Also See

LineArcIntersection

LineBoxIntersection

LineCylinderIntersection

LineLineIntersection

LinePlaneIntersection

LineSphereIntersection