MovePlane

Moves the origin of a plane.

Syntax

Rhino.MovePlane (arrPlane, arrOrigin)

Parameters

arrPlane

Required.  Array.  The plane.  The elements of a plane array are as follows:

Element

Description

0

Required.  The plane's origin (3-D point).

1

Required.  The plane's X axis direction (3-D vector).

2

Required.  The plane's Y axis direction (3-D vector).

3

Optional.  The plane's Z axis direction (3-D vector).

arrOrigin

Required.  Array.  A 3-D point identifying the new origin location.

Returns

Array

The plane if successful.  The elements of a plane array are as follows:

Element

Description

0

The plane's origin (3-D point).

1

The plane's X axis direction (3-D vector).

2

The plane's Y axis direction (3-D vector).

3

The plane's Z axis direction (3-D vector).

Null

If not successful, or on error.

Example

Dim arrPlane, arrOrigin

arrOrigin = Rhino.GetPoint("CPlane origin")

If IsArray(arrOrigin) Then

  arrPlane = Rhino.ViewCPlane

  If IsArray(arrPlane) Then

    Rhino.ViewCPlane , Rhino.MovePlane(arrPlane, arrOrigin)

  End If

End If

Also See

PlaneFromFrame

PlaneFromNormal

RotatePlane