PlaneAngle

Calculates the angle between two points that lie on a given plane.

Syntax

Rhino.PlaneAngle (arrPlane, arrBasePoint, arrRefPoint1, arrRefPoint2)

Parameters

arrPlane

Required.  Array.  The plane on which the points lie.

arrBasePoint

Required.  Array.  The base point.

arrRefPoint1

Required.  Array.  The first reference point.

arrRefPoint2

Required.  Array.  The second reference point.

Returns

Number

The angle in degrees if successful.

Null

If not successful, or on error.

Example

Dim arrPlane, arrBasePoint

Dim arrPoint1, arrPoint2, arrRefPoint1, arrRefPoint2

arrPlane = Rhino.WorldXYPlane

arrBasePoint = Array(0,0,0)

arrPoint1 = Rhino.GetPoint("First angle point", arrBasePoint)

arrPoint2 = Rhino.GetPoint("Second angle point", arrBasePoint)

arrRefPoint1 = Rhino.PlaneClosestPoint(arrPlane, arrPoint1)

arrRefPoint2 = Rhino.PlaneClosestPoint(arrPlane, arrPoint2)

Rhino.Print Rhino.PlaneAngle(arrPlane, arrBasePoint, arrRefPoint1, arrRefPoint2)

Also See

Angle

Angle2

Distance