Returns the equation of a plane. The standard equation of a plane with a non-zero normal vector is as follows:
Ax + By + Cz + D = 0
Rhino.PlaneEquation (arrPlane)
arrPlane |
Required. Array. The plane. The elements of a plane array are as follows:
|
Array |
An array containing four numbers that represent the coefficients of the equation, if successful. |
Null |
If not successful, or on error. |
Dim arrPlane, arrEquation
arrPlane = Rhino.ViewCPlane
arrEquation = Rhino.PlaneEquation
Rhino.Print "A = " & CStr(arrEquation(0))
Rhino.Print "B = " & CStr(arrEquation(1))
Rhino.Print "C = " & CStr(arrEquation(2))
Rhino.Print "D = " & CStr(arrEquation(3))