MaterialBump

Returns or modifies a material's bump bitmap filename.

Syntax

Rhino.MaterialBump (intMaterialIndex [, strFileName])

Parameters

intMaterialIndex

Required.  Number.  The zero-based source material index.

strFileName

Optional.  String.  The bump bitmap filename.

Returns

String

If strFileName is not specified, the current bump bitmap filename if successful.

String

If strFileName is specified, the previous bump bitmap filename if successful.

Null

It not successful, or on error.

Example

Dim strObject, intIndex

strObject = Rhino.GetObject("Select object")

If Not IsNull(strObject) Then

intIndex = Rhino.ObjectMaterialIndex(strObject)

If (intIndex > -1) Then

Rhino.MaterialBump intIndex, "C:\Windows\Coffee Bean.bmp"

End If

End If

Also See

MaterialColor

MaterialName

MaterialReflectiveColor

MaterialShine

MaterialTexture

MaterialTransparency