Returns or modifies a material's texture bitmap filename.
Rhino.MaterialTexture (intMaterialIndex [, strFileName])
intMaterialIndex |
Required. Number. The zero-based source material index. |
strFileName |
Optional. String. The texture bitmap filename. |
String |
If strFileName is not specified, the current texture bitmap filename if successful. |
String |
If strFileName is specified, the previous texture bitmap filename if successful. |
Null |
It not successful, or on error. |
Dim strObject, intIndex
strObject = Rhino.GetObject("Select object")
If Not IsNull(strObject) Then
intIndex = Rhino.ObjectMaterialIndex(strObject)
If (intIndex > -1) Then
Rhino.MaterialTexture intIndex, "C:\Windows\Coffee Bean.bmp"
End If
End If