Returns the 3-D point that is a specified angle and distance from a 3-D point.
Rhino.Polar (arrPoint, dblAngle, dblDistance [, arrPlane])
arrPoint |
Required. Array. The 3-D point to transform. |
||||||||
dblAngle |
Required. Number. The angle in degrees. |
||||||||
dblDistance |
Required. Number. The distance. |
||||||||
arrPlane |
Optional. Array. The plane to base the transformation. Of omitted, the world x-y plane is used. The elements of a plane array are as follows:
|
Array |
The resulting 3-D point if successful. |
Null |
On error. |
Dim arrPoint, arrResult
arrPoint = Array(1.0, 1.0, 0.0)
arrResult = Rhino.Polar(arrPoint, 45.0, 1.414214)
Rhino.Print Rhino.Pt2Str(arrResult)