ExtractAnalysisMesh

Extracts the mesh created by the CurvatureAnalysis or DraftAngleAnalysis commands from an object. The vertex color assignments are saved with the mesh. Surfaces, polysurfaces, meshes, block references, and extrusions can contain analysis meshes. Note, if the object does not have an analysis mesh, one will be generated automatically.

Syntax

Rhino.ExtractAnalysisMesh (strObject)

Rhino.ExtractAnalysisMesh (arrObjects)

Parameters

strObject

Required.  String.  The identifier of the object from which to extract the mesh.

arrObjects

Required.  Array.   An array of strings identifying the objects from which to extract the meshes.

Returns

String

If strObject was specified, the identifier of the newly created mesh object if successful.

Array

If arrObjects was specified, an array of strings identifying the newly created mesh objects if successful.

Null

If not successful, or on error.

Example

Const rhSurface = 8

Const rhPolysrf = 16

Const rhMesh = 32

Const rhBlock = 4096

Const rhExtrusion = 1073741824

Dim strObject, intFlags

intFlags = rhSurface + rhPolysrf + rhMesh + rhBlock + rhExtrusion

strObject = Rhino.GetObject("Select object to extract analysis mesh", intFlags)

If Not IsNull(strObject) Then

Rhino.ExtractAnalysisMesh strObject

End If

Also See

ExtractRenderMesh