Mesh Methods

The following methods are available for creating, querying or manipulating mesh objects.   

 

Method

Description

AddMesh

Adds a mesh object.

AddPlanarMesh

Creates a planar mesh from a closed, planar curve.

ConnectedMeshFaces

Returns a set of faces from a joined mesh based at a break angle.

CurveMeshIntersection

Calculates the intersection of a curve with a mesh.

DeletesMeshFace

Deletes one or more faces from a mesh object.

DisjointMeshCount

Returns the number of meshes that could be created by calling SplitDisjointMesh.

DuplicateMeshBorder

Creates a curve that duplicates a mesh border.

ExplodeMeshes

Explodes one or more mesh objects.

ExtractAnalysisMesh

Copies the analysis mesh to create a separate mesh object.

ExtractRenderMesh

Copies the render mesh to create a separate mesh object.

FlipMesh

Reverses the normal direction of a mesh object.

IsMesh

Verifies an object is a mesh object.

IsMeshClosed

Verifies a mesh object is closed.

IsMeshDoublePrecision

Verifies that a mesh object contains double-precision vertices.

IsMeshManifold

Verifies that a mesh is manifold.

IsPointOnMesh

Verifies that a point is on a mesh.

JoinMeshes

Joins two or more mesh object together to form a single mesh object.

MeshArea

Returns the area of a mesh object.

MeshAreaCentroid

Calculates the area centroid of a mesh object.

MeshAreaMoments

Calculates the area moments of inertia of a mesh object.

MeshBooleanDifference

Performs a Boolean difference operation on two sets of input meshes.

MeshBooleanIntersection

Performs a Boolean intersection operation on two sets of input meshes.

MeshBooleanSplit

Performs a Boolean split operation on two sets of input meshes.

MeshBooleanUnion

Performs a Boolean union operation on a set of input meshes.

MeshClosestPoint

Returns the point on a mesh that is closest to a test point.

MeshContourPoints

Returns the vertices of the polyline curves generated by contouring a mesh.

MeshFaceCenters

Returns the center point of the faces of a mesh object.

MeshFaceCount

Returns the face count of a mesh object.

MeshFaceNormals

Returns the unitized face normals for a mesh object.

MeshFaces

Returns the faces of a mesh object.

MeshFaceVertices

Returns the vertex indices of all faces of a mesh object.

MeshHasFaceNormals

Verifies a mesh object has face normals.

MeshHasHiddenVertices

Verifies that a mesh object has hidden vertices.

MeshHasTextureCoordinates

Verifies a mesh object has texture coordinates.

MeshHasVertexColors

Verifies a mesh object has vertex colors.

MeshHasVertexNormals

Verifies a mesh object has vertex normals.

MeshHideVertices

Returns or modifies the hidden vertices of a mesh object.

MeshMeshIntersection

Calculates the intersection of a mesh object with another mesh object.

MeshNakedEdgePoints

Identifies the naked edge points of a polygon mesh object.

MeshObjects

Meshes one or more meshable objects.

MeshOffset

Offsets a mesh object.

MeshOutline

Creates a polyline outline of mesh objects.

MeshParameterDensity

Modifies the density of mesh parameters.

MeshParameters

Returns of modifies meshing parameters.

MeshPart

Returns a set of faces of a mesh that are bounded by unwelded edges.

MeshPatch

Creates a polygon mesh from curves and points.

MeshQuadCount

Returns the number of quad mesh faces of a mesh object.

MeshQuadsToTriangles

Converts a mesh object's quad faces to triangles.

MeshTextureCoordinates

Returns the texture coordinates of a mesh object.

MeshToNurb

Duplicates each polygon in a polygon mesh with a NURBS surface.

MeshTriangleCount

Returns the number of triangular mesh faces of a mesh object.

MeshVertexColors

Returns or modifies the vertex colors of a mesh object.

MeshVertexCount

Returns the vertex count of a mesh object.

MeshVertexFaces

Returns the mesh faces that share a mesh vertex.

MeshVertexNormals

Returns the unitized vertex normals for a mesh object.

MeshVertices

Returns the vertices of a mesh object.

MeshVolume

Returns the volume of a closed mesh object.

MeshVolumeCentroid

Calculates the volume centroid of a mesh object.

MeshVolumeMoments

Calculates the volume moments of inertia of a mesh object.

PullCurveToMesh

Pulls a curve object to a mesh object.

ReduceMesh

Reduces a mesh object's polygon count.

SmoothMesh

Smooths a mesh object.

SplitDisjointMesh

Splits up a mesh object into its unconnected pieces.

UnifyMeshNormals

Fixes inconsistencies in the directions of faces of a mesh object.

UnweldMesh

Unwelds a mesh.

WeldMesh

Welds a mesh.