JoinMeshes

Joins two or more mesh object together to form a single mesh object.

Syntax

Rhino.JoinMeshes (arrObjects [, blnDelete])

Parameters

arrObjects

Required.  Array.  An array of strings identifying the mesh objects to join.

blnDelete

Optional.  Boolean.  Delete input objects after joining.  The default is not to delete objects (False).

Returns

String

The identifier of  the newly created mesh object if successful.

Null

If not successful, or on error.

Example

Const rhObjectMesh = 32

Dim arrObjects

arrObjects = Rhino.GetObjects("Select meshes to join", rhObjectMesh)

If UBound(arrObjects) > 0 Then

Rhino.JoinMeshes arrObjects, True

End If

Also See

JoinCurves

JoinSurfaces