MeshFaceNormals

Returns the face unit normal for each face of a mesh object.  

Syntax

Rhino.MeshFaceNormals (strObject)

Parameters

strObject

Required.  String.  The identifier of a mesh object.

Returns

Array

An array of 3-D vectors that define the face unit normals of the mesh if successful.  The number of elements in the array will be equal to the value returned by MeshFaceCount. In which case, the array will identify the unit normals for each face return by MeshFaces.

Null

If not successful, or on error.

Example

Const rhObjectMesh = 32

Dim strObject, arrNormals, arrVector

strObject = Rhino.GetObject("Select mesh", rhObjectMesh)

arrNormals = Rhino.MeshFaceNormals(strObject)

If IsArray(arrNormals) Then

For Each arrVector in arrNormals

Rhino.Print CStr(arrVector(0)) & "," & CStr(arrVector(1)) & "," & CStr(arrVector(2))

Next

End If

Also See

MeshHasFaceNormals

MeshFaceCount

MeshFaces