MeshParameters
Returns or modifies meshing parameters. Note, Rhino's meshing parameters
are well documented in the Rhino help file. Just search for "Polygon
Mesh Detailed Options."
Syntax
Rhino.MeshParameters (intType [, arrMeshParameters])
Parameters
intType |
Optional.
Number. The type of mesh parameters to return or modify.
If omitted, Rhino's current render mesh parameters are returned.
Value |
Description |
0 |
Render mesh parameters. These
document settings are used for automatically created rendering
meshes. |
1 |
Analysis mesh parameters. These
document settings are used for automatically created analysis
meshes. |
2 |
Custom render mesh parameters.
These document setting can be viewed by using the
Options command
and clicking on the Mesh
tab. |
3 |
Fast mesh parameters. Also
know as "jagged and faster", these document
setting can be viewed by using the Options
command and clicking on the Mesh
tab. Note, these parameters cannot be modified. |
4 |
Quality mesh parameters. Also
know as "smooth and slower", these document
setting can be viewed by using the Options
command and clicking on the Mesh
tab. Note, these parameters cannot be modified. |
|
arrMeshParameters |
Optional.
Array. The new mesh parameters to use during meshing.
A mesh parameters array contains the following information.
Element |
Value |
Description |
0 |
Number |
Density |
1 |
Number |
Maximum angle |
2 |
Number |
Maximum aspect ratio |
3 |
Number |
Minimum edge length |
4 |
Number |
Maximum edge length |
5 |
Number |
Maximum distance, edge to surface |
6 |
Number |
Minimum initial grid quads |
7 |
Boolean |
Refine mesh |
8 |
Boolean |
Jagged seams |
9 |
Boolean |
Simple planes |
10 |
Boolean |
Pack textures |
|
Returns
Array |
If
arrMeshParameters was
not specified, the current mesh parameters of the specified type
if successful. |
String |
If
arrMeshParameters was
specified, the previous mesh parameters of the specified type
if successful. |
Null |
If
not successful, or on error. |
Example
arrObjects = Rhino.GetObjects("Select
objects to mesh")
If IsArray(arrObjects) Then
arrMP = Rhino.MeshParameters(0)
Rhino.MeshObjects
arrObjects, -1, arrMP
End If
Also See
MeshObjects