Named Position Methods

Rhino's NamedPosition command allows you to save the locations of objects and restore them at a later time.  The command is implemented in the Named Positions plug-in, or NamedPositions.rhp. Because the NamedPosition command resides in a plug-in, you will first need to get the plug-in's scriptable object, using GetPlugInObject, before you can call any of these methods.

For example:

 

Sub TestNamedPositions

  Dim objPlugIn

  On Error Resume Next

  Set objPlugIn = Rhino.GetPluginObject("Named Position")

  If Err Then

    MsgBox Err.Description

    Exit Sub

  End If

  'TODO: call a named position method...

End Sub

 

Method

Description

AppendNamedPosition

Adds objects to an existing named position..

DeleteNamedPosition

Deletes a named position.

NamedPositionCount

Returns the number of named positions.

NamedPositions

Returns the names of the named positions.

RenameNamedPosition

Renames an existing named position.

RestoreNamedPosition

Restores an existing named position.

SaveNamedPosition

Saves a new named position.

SelectObjectsOfNamedPosition

Select the objects of a named position.

UpdateNamedPosition

Updates an existing named position.