NamedPositions

Returns the names of all named positions in the document.

Syntax

Rhino.NamedPositions ([blnSort])

Parameters

blnSort

Optional.  Boolean.  If not specified or True, then the named position names are sorted in ascending order. If False, then the named position names are return in the order in which they were saved.

Returns

Array

An array of named position names if successful.

Null

If not successful, or on error.

Example

Sub TestNamedPositions

  Dim objPlugIn, arrNames, strName

  On Error Resume Next

  Set objPlugIn = Rhino.GetPluginObject("Named Position")

  If Err Then

    MsgBox Err.Description

    Exit Sub

  End If

  arrNames = objPlugIn.NamedPositions

  If IsArray(arrNames) Then

    For Each strName in arrNames

      Call Rhino.Print(strName)

    Next

  End If

End Sub

Also See

AppendNamedPosition

DeleteNamedPosition

NamedPositionCount

RenameNamedPosition

RestoreNamedPosition

SaveNamedPosition

SelectObjectsOfNamedPosition

UpdateNamedPosition