Returns or modifies the print width source of an object. The width used to print objects is specified in one of three ways:
Print width from layer. Use the print width assigned to the object's layer.
Print width from object. Use the print width that is assigned to the object.
Print width from parent. For objects with parents, like objects in block instances, use parent's print width. If no parent, treats as print width from layer.
Rhino.ObjectPrintWidthSource (strObject [, intSource])
Rhino.ObjectPrintWidthSource (arrObjects, intSource)
strObject |
Required. String. The identifier of the object. |
||||||||||
arrObjects |
Required. Array. An array of strings identifying the objects to modify. |
||||||||||
intSource |
Optional. Number. The new print width source. If omitted, the current print width source is returned. Note, if arrObjects is specified, intSource is required.
|
Number |
If a print width source is not specified, the current width source if successful. |
Number |
If a print width source is specified, the previous width source if successful. |
Number |
If arrObjects is specified, then the number of objects modified if successful. |
Null |
If not successful, or on error. |
Dim arrObjects, strObject
arrObjects = Rhino.GetObjects("Select objects to reset print width source")
If IsArray(arrObjects) Then
For Each strObject In arrObjects
Rhino.ObjectPrintWidthSource strObject, 0
Next
End If