Object Methods

The following methods are available for querying or manipulating the general properties of Rhino objects.

 

Method

Description

AddObjectDisplayMode

Assigns separate display attributes to individual objects.

AddObjectMesh

Adds custom render mesh parameters to an object.

BendObject

Deforms objects by bending along a spine arc.

BoxMorphObject

Bounding box morphs an object.

ChangeObjectSpace

Changes the space of objects.

CopyObject

Copies a single object.

CopyObjects

Copies one or more objects.

DeleteObject

Deletes a single object.

DeleteObjects

Deletes one or more objects.

EnableObjectMesh

Enables or disables an object's custom render mesh parameters.

FlashObject

Flashes one or more objects

FlowObject

Re-aligns objects from a base curve to a target curve.

HideObject

Hides a single object.

HideObjects

Hides one or more objects.

IsLayoutObject

Verifies that an object resides in either layout or model space.

IsObject

Verifies an object exist.

IsObjectChild

Verifies that an object is a history descendant, or child object.

IsObjectHidden

Verifies an object is hidden.

IsObjectInBox

Verifies an object's bounding box is inside of another bounding box.

IsObjectInGroup

Verifies an object is a member of a group.

IsObjectLocked

Verifies an object is locked.

IsObjectNormal

Verifies an object has normal display attributes.

IsObjectParent

Verifies that an object is a history antecedent, or parent object.

IsObjectReference

Verifies an object is a reference object.

IsObjectSelectable

Verifies an object can be selected.

IsObjectSelected

Verifies an object is selected.

IsObjectSolid

Verifies an object is closed, solid object

IsObjectValid

Verifies an object's geometry is valid.

IsVisibleInView

Verifies an object is visible in a view.

LockObject

Locks a single object.

LockObjects

Locks one or more objects.

MaelstromObject

Deforms objects in a spiral as if they were caught in a whirlpool.

MatchObjectAttributes

Matches the attributes of one object to another.

MirrorObject

Mirrors a single object.

MirrorObjects

Mirrors one or more objects.

MoveObject

Moves a single object.

MoveObjects

Moves one or more objects.

ObjectCastsShadows

Returns or sets an object's casts shadows property.

ObjectChildren

Returns the identifiers of history descendants, or children, of a parent object.

ObjectClash

Performs clash and clearance analysis.

ObjectColor

Returns or changes an object's color.

ObjectColorSource

Returns or changes an object's color source.

ObjectDataCRC

Returns the CRC value of an object's data, or geometry.

ObjectDescription

Returns a short text description of the object.

ObjectDisplayMode

Returns an object's display mode.

ObjectDump

Returns a detailed description of the object.

ObjectGroups

Returns an object's groups.

ObjectHasHistory

Verifies that an object has history.

ObjectHasMesh

Verifies that an object has custom render mesh parameters.

ObjectLayer

Returns or changes an object's layer.

ObjectLayout

Returns or changes the layout or model space of an object.

ObjectLinetype

Returns or changes an object's linetype.

ObjectLinetypeSource

Returns or changes an object's linetype source.

ObjectMaterialIndex

Returns or changes an object's rendering material index.

ObjectMaterialSource

Returns or changes an object's rendering material source.

ObjectMeshDensity

Returns or modifies an object's custom render mesh density parameter.

ObjectMeshMaxAngle

Returns or modifies an object's custom render mesh maximum angle parameter.

ObjectMeshMaxAspectRatio

Returns or modifies an object's custom render mesh maximum aspect ratio parameter.

ObjectMeshMaxDistEdgeToSrf

Returns or modifies an object's custom render mesh maximum distance, edge to surface parameter.

ObjectMeshMaxEdgeLength

Returns or modifies an object's custom render mesh maximum edge length parameter.

ObjectMeshMinEdgeLength

Returns or modifies an object's custom render mesh minimum edge length parameter.

ObjectMeshMinInitialGridQuads

Returns or modifies an object's custom render mesh minimum initial grid quads parameter.

ObjectMeshQuality

Returns or modifies an object's custom render mesh quality parameter.

ObjectMeshSettings

Returns or modifies an object's custom render mesh settings.

ObjectName

Returns or changes an object's name.

ObjectNames

Returns or changes the names of one or more objects.

ObjectParents

Returns the identifiers of history antecedents, or parents, of an object.

ObjectPrintColor

Returns or changes an object's print color.

ObjectPrintColorSource

Returns or changes an object's print color source.

ObjectPrintWidth

Returns or changes an object's print width.

ObjectPrintWidthSource

Returns or changes an object's print width source.

ObjectReceivesShadows

Returns or sets an object's receives shadows property.

ObjectSerialNumber

Returns the unique serial number of an object.

ObjectSpace

Returns the active working space of an object.

ObjectTopGroup

Returns an object's top-level groups.

ObjectType

Returns an object's type.

ObjectURL

Returns or changes an object's URL.

OrientObject

Orients a single object.

OrientObjects

Orients one or more objects.

RemapObject

Remaps an object to a different coordinate system.

RemapObjects

Remaps one or more objects to a different coordinate system.

RemoveObjectDisplayMode

Removes separate display attributes to individual objects.

ReplaceGeometry

Replaces the geometry of an object with that of another object.

RotateObject

Rotates a single object.

RotateObjects

Rotates one or more objects.

ScaleObject

Scales a single object.

ScaleObjects

Scales one or more objects.

SelectObject

Selects a single object.

SelectObjects

Selects one or more objects.

ShearObject

Shears a single object.

ShearObjects

Shears one or more objects.

ShowObject

Shows, or unhides, a single object.

ShowObjects

Shows, or unhides, one or more object.

SplopObject

Copies, rotates, scales, and wraps objects on a surface

SporphObject

Deforms an object from a source surface to a target surface.

StretchObject

Deforms an object by scaling selected portions in one direction.

TaperObject

Deforms objects toward or away from a specified axis.

TransformObject

Moves, scales, or rotates a single object.

TransformObjects

Moves, scales, or rotates one or more objects.

TwistObject

Deforms objects by rotating them around an axis.

UnlockObject

Unlocks a single object.

UnlockObjects

Unlocks one or more objects.

UnselectObject

Unselects a single object.

UnselectObjects

Unselects one or more objects.