SplopObject

Rotates, scales, and wraps objects on a surface.

Syntax

Rhino.SplopObject (strObject, arrPlane, strSurface, arrParam, [, dblScale, [, dblAngle, blnCopy]]])

Rhino.SplopObject (arrObjects, arrPlane, strSurface, arrParam, [, dblScale, [, dblAngle, blnCopy]]])

Parameters

strObject

Required. String. The identifier of the object to deform.

arrObjects

Required. Array. An array of strings identifying the objects to deform.

arrPlane

Required. Array. The source plane of the deformation.

strSurface

Required. String. The identifier of the surface to wrap the objects onto.

arrParam

Required. Array. The u,v parameter on strSurface used for orienting the surface.

dblScale

Optional. Number. The scale factor. If omitted, the objects will not be scaled.

dblAngle

Optional. Number. The rotation angle in degrees. If omitted, the objects will not be rotated.

blnCopy

Optional. Array. Copy the object. If omitted, the object(s) will not be copied (False).

Returns

String

The identifier of the deformed object if successful.

Array

An array of strings identifying the deformed objects if successful.

Null

If not successful, or on error.

Example

Dim strObject, arrPoint, arrPlane, arrSurface

strObject = Rhino.GetObject("Select object to splop")

arrPoint = Rhino.GetPoint("Base point")

arrPlane = Rhino.MovePlane(Rhino.WorldXYPlane, arrPoint)

arrSurface = Rhino.GetSurfaceObject("Select surface to splop on")

Rhino.SplopObject strObject, arrPlane, arrSurface(0), arrSurface(4),,,True

Also See

BendObject

BoxMorphObject

FlowObject

MaelstromObject

StretchObject

TaperObject

TwistObject