The following methods are available for creating and manipulating 3-D points and 3-D vectors. 3-D points and 3-D vectors are represented as zero-based, one-dimensional arrays that contain three numbers. For more information, see the Points and Vectors discussion in RhinoScript Fundamentals.
Method |
Description |
Compares two vectors to see if they are parallel. |
|
Compares two vectors to see if they are perpendicular. |
|
Verifies a vector is tiny. |
|
Verifies a vector is zero. |
|
Adds a point or a vector to a point. |
|
Returns the bounding box of an array of 3-D points. |
|
Finds the point in an array of 3-D points that is closest to a test point. |
|
Transforms an array of 3-D points. |
|
Finds the object that is closest to a test point. |
|
Compares two points. |
|
Divides a point by a value. |
|
Verifies that a list of 3-D points are coplanar. |
|
Scales a point by a value. |
|
Subtracts a point or a vector from a point. |
|
Transforms a point. |
|
Projects one or more points onto one or more meshes. |
|
Projects one or more points onto one or more surfaces or polysurfaces. |
|
Pulls points to a surface or a mesh object. |
|
Adds two vectors. |
|
Returns the angle between two 3-D vectors. |
|
Compares two vectors. |
|
Create a vector from two 3-D points. |
|
Returns the cross product of two vectors. |
|
Divides a vector. |
|
Returns the dot product of two vectors. |
|
Returns the length of a vector. |
|
Multiplies two vectors. |
|
Reverses a vector. |
|
Rotates a vector. |
|
Scales a vector. |
|
Subtracts two vectors. |
|
Transforms a vector. |
|
Unitizes, or normalizes, a vector. |