Returns the identifiers of all objects in the document, including reference objects. This includes object that are normal (neither hidden nor locked), hidden, and locked objects.
Rhino.AllObjects ([blnSelect [, blnIncludeLights [, blnIncludeGrips]]])
blnSelect |
Optional. Boolean. Select the objects. If omitted, the objects are not selected (False). |
blnIncludeLights |
Optional. Boolean. Include light objects. If omitted, light objects are not returned (False). |
blnIncludeGrips |
Optional. Boolean. Include grips objects. If omitted, grips objects are not returned (False). |
Array |
An array of strings identifying the objects if successful. |
Null |
If not successful, or on error. |
Dim arrObjects, strObject
arrObjects = Rhino.AllObjects
If IsArray(arrObjects) Then
For Each strObject In arrObjects
Rhino.Print "Object identifier: " & strObject
Next
End If