Returns the identifiers of all hidden objects in the document, including reference objects. Hidden objects are not visible, cannot be snapped to, and cannot be selected.
Both the object's hidden status, as well as the object layer's hidden status, are used to determine whether or not the object is returned.
Rhino.HiddenObjects ([blnIncludeLights [, blnIncludeGrips]])
blnIncludeLights |
Optional. Boolean. Include light objects. If omitted, light objects are not returned (False). |
blnIncludeGrips |
Optional. Boolean. Include grips objects. If omitted, grips objects are not returned (False). |
Array |
An array of strings identifying the objects if successful. |
Null |
If not successful, or on error. |
Dim arrObjects, strObject
arrObjects = Rhino.HiddenObjects
If IsArray(arrObjects) Then
For Each strObject In arrObjects
Rhino.Print "Object identifier: " & strObject
Next
End If