SelectedObjects

Returns the identifiers of all objects that are currently selected.

Syntax

Rhino.SelectedObjects ([blnIncludeLights [, blnIncludeGrips]])

Parameters

blnIncludeLights

Optional.  Boolean.  Include light objects.  If omitted, light objects are not returned (False).

blnIncludeGrips

Optional.  Boolean.  Include grips objects.  If omitted, grips objects are not returned (False).

Returns

Array

An array of strings identifying the objects if successful.

Null

If not successful, or on error.

Example

Dim arrObjects, strObject

arrObjects = Rhino.SelectedObjects

If IsArray(arrObjects) Then

For Each strObject In arrObjects

Rhino.Print "Object identifier: " & strObject

Next

End If

Also See

InvertSelectedObjects

UnselectAllObjects

UnselectedObjects