UnselectedObjects

Returns the identifiers of all objects that are currently unselected.

Syntax

Rhino.UnselectedObjects ([blnSelect [, blnIncludeLights [, blnIncludeGrips]]])

Parameters

blnSelect

Optional.  Boolean.  Select the objects.  If omitted, the object is not selected (False).

blnIncludeLights

Optional.  Boolean.  Include light objects.  If omitted, light objects are not returned (False).

blnIncludeGrips

Optional.  Boolean.  Include grips objects.  If omitted, grips objects are not returned (False).

Returns

Array

An array of strings identifying the objects if successful.

Null

If not successful, or on error.

Example

Dim arrObjects, strObject

arrObjects = Rhino.UnselectedObjects

If IsArray(arrObjects) Then

For Each strObject In arrObjects

Rhino.Print "Object identifier: " & strObject

Next

End If

Also See

InvertSelectedObjects

SelectedObjects

UnselectAllObjects