ChangeSurfaceDegree

Changes the degree of a surface object.  For more information see the Rhino help file for the ChangeDegree command.

Syntax

Rhino.ChangeSurfaceDegree (strObject, arrDegree [, blnDeformable])

Parameters

strObject

Required.  String.  The object's identifier.

arrDegree

Required.  Array.  The new degree in both the U and V directions.

blnDeformable

Required.  Number.  If True, and the degree of the surface is different from the requested degree, the new surface has simple interior knots.  If False, and the degree of the surface is LESS than the requested degree, the new surface will have exactly the same geometry and parameterization as the original, but it will have knots of multiplicity = old multiplicity + new degree - old degree.  If the degree of the surface is GREATER than the requested degree, then the new surface will be an approximation of the original with simple knots. The default value is False.

Returns

Boolean

True of False indicating success or failure.

Null

On error.

Example

Dim strSurface, arrDegree(1)

strSurface = Rhino.GetObject("Select surface", 8)

If Not IsNull(strSurface) Then

  arrDegree(0) = Rhino.SurfaceDegree(strSurface, 0) + 1

  arrDegree(1) = Rhino.SurfaceDegree(strSurface, 1) + 1

  Call Rhino.ChangeSurfaceDegree(strSurface, arrDegree)

End If

Also See

IsSurface

SurfaceDegree