Surface & Polysurface Methods

The following methods are available for creating, querying or manipulating surface and polysurface objects.

 

Method

Description

AddBox

Adds a box object.

AddCone

Add a cone object.

AddCutPlane

Adds a planar surface through objects at a designated location.

AddCylinder

Adds a cylinder object.

AddEdgeSrf

Adds a surface from edge curves.

AddExtrusion

Adds a lightweight extrusion object to the document.

AddLoftSrf

Adds a surface by lofting curves.

AddNetworkSrf

Creates a surface from a network of crossing curves.

AddNetworkSrfEx

Creates a surface from a network of crossing curves.

AddNurbsSurface

Adds a NURBS surface.

AddPatch

Fits a surface through curve, point, point cloud, and mesh objects.

AddPipe

Creates a singled-walled surface with a circular profile around a curve.

AddPlanarSrf

Creates one or more surfaces from planar curves.

AddPlaneSurface

Creates a plane surface from three non-colinear points.

AddRailRevSrf

Adds a rail-revolved surface.

AddRevSrf

Adds a revolved surface.

AddSphere

Adds a sphere object.

AddSrfContourCrvs

Adds the curves generated by contouring a surface or polysurface.

AddSrfControlPtGrid

Creates a surface from a grid of control points.

AddSrfPt

Creates a surface from corner points.

AddSrfPtGrid

Creates a surface from a grid of points.

AddSrfSectionCrvs

Adds the curves generated by sectioning a surface or polysurface.

AddSweep1

Adds a surface created through profile curves that define the surface shape and one curve that defines a surface edge.

AddSweep2

Adds a surface created through profile curves that define the surface shape and two curves that define the surface edges.

AddThickPipe

Creates a double-walled surface with a circular profile around a curve.

AddTorus

Adds a torus object.

AddTruncatedCone

Adds a truncated cone to the document.

BooleanDifference

Boolean difference function.

BooleanIntersection

Boolean intersection function.

BooleanUnion

Boolean union function.

BoxPoints

Returns the corner points of a polysurface box.

BrepClosestPoint

Returns the point on a polysurface, or brep, that is closest to a test point.

CapPlanarHoles

Cap planar holes in a surface or polysurface.

ChangeSurfaceDegree

Changes the degree of a surface object.

ConvertExtrusion

Converts an extrusion object to a Brep object.

ConvertSurfaceToBezier

Changes the structure of a NURBS surface to a Bézier surface.

CreateSolid

Creates a closed polysurface from surfaces and polysurfaces that bound a region in space.

DuplicateEdgeCurves

Duplicates the edge curves of a surface or polysurface.

DuplicateSurfaceBorder

Creates a curve that duplicates a surface or polysurface border.

EvaluateSurface

Evaluates a surface point at a U,V parameter.

ExplodePolysurface

Explodes one or more polysurface objects.

ExtendSurface

Lengthens a surface by a factor value.

ExtractIsoCurve

Extracts isoparametric curves from a surface object.

ExtractSurface

Separates or copies a surface or a copy of a surface from a polysurface.

ExtrudeCurve

Extrudes a curve along a path.

ExtrudeCurveNormal

Extrudes a curve normal to a surface.

ExtrudeCurvePoint

Extrudes a curve to a point.

ExtrudeCurveStraight

Extrudes a curve straight.

ExtrudeCurveTapered

Extrudes a curve to a taper.

ExtrudeSurface

Extrudes a surface along a path.

FilletSurfaces

Create constant radius rolling ball fillets between two surfaces.

FilletSurfacesEx

Creates a surface between two surfaces and adds it to the document.

FitSurface

Fits a new surface through an existing surface.

FlipSurface

Returns or modifies the normal direction of a surface.

InsertSurfaceKnot

Inserts a knot into a surface object.

IntersectBreps

Calculates the intersection of two brep objects.

IntersectSpheres

Calculates the intersection of two spheres.

IsBox

Verifies that a polysurface is a box.

IsBrep

Verifies an object is a Brep.

IsBrepManifold

Verifies that a surface or polysurface is manifold.

IsCone

Determines if a surface is a portion of a cone.

IsCylinder

Determines if a surface is a portion of a cylinder.

IsExtrusion

Verifies that an object is an extrusion object.

IsNurbsSurface

Verifies an object is a NURBS surface.

IsParameterOnSurface

Verifies that a parameter space point is on a trimmed surface.

IsPlaneSurface

Verifies an object is a plane surface.

IsPointInSurface

Verifies a point is inside a closed surface or polysurface.

IsPointOnSurface

Verifies a point is on a surface.

IsPolysurface

Verifies an object is a polysurface.

IsPolysurfaceClosed

Verifies a a polysurface object is closed.

IsPolysurfacePlanar

Verifies a a polysurface object is planar.

IsRevSurface

Verifies an object is a surface of revolution.

IsSphere

Determines if a surface is a portion of a sphere.

IsSumSurface

Verifies an object is a sum, or extruded, surface.

IsSurface

Verifies an object is a surface.

IsSurfaceClosed

Verifies a surface object is closed.

IsSurfacePeriodic

Verifies a surface object is periodic.

IsSurfacePlanar

Verifies a surface object is planar.

IsSurfaceRational

Verifies a surface object is rational.

IsSurfaceSingular

Verifies a surface object is singular.

IsSurfaceTrimmed

Verifies a surface object is a trimmed surface.

IsSurfaceUnrollable

Verifies that a surface or polysurface can be unrolled (developed).

IsTorus

Determines if a surface is a portion of a torus.

JoinSurfaces

Joins two or more surface or polysurface objects.

JoinSurfacesEx

Joins two or more surface or polysurface objects.

MakeSurfacePeriodic

Makes a surface object periodic.

MergeSurfaces

Merges two surfaces into one surface at untrimmed edges.

OffsetBrep

Offsets a surface or a polysurface.

OffsetSurface

Offsets a surface.

PullCurve

Pulls a curve object to a surface object.

RebuildSurface

Rebuilds a surface to a given point count.

RemoveSurfaceKnot

Removes a knot-line from a surface.

ReverseSurface

Reverses the U and V directions of a surface object.

ShootRay

Shoots a ray at a collection of surfaces.

ShortPath

Creates the shortest possible curve (geodesic) between two points on a surface.

ShrinkTrimmedSurface

Shrinks a surfaces or polysurfaces underlying untrimmed surfaces near to trimming boundaries.

SmoothSurface

Smooths a surface object.

SoftEditSurface

Soft edits a surface object.

SplitBrep

Splits a brep with another brep.

SplitSurface

Splits a surface at a surface parameter.

SplitSurfaceEx

Splits a surface into pieces using trimming curves.

SurfaceArea

Calculates the area of a surface or polysurface object.

SurfaceAreaCentroid

Calculates the area centroid of a surface or polysurface object.

SurfaceAreaMoments

Calculates the area moments of inertia of surface or polysurface objects.

SurfaceClosestPoint

Returns the u,v parameter of the point on a surface that is closest to a test point.

SurfaceCone

Returns the definition of a cone surface.

SurfaceContourPoints

Returns the vertices of the polyline curves generated by contouring a surface or polysurface.

SurfaceCount

Returns the number of surfaces, or faces, in a polysurface.

SurfaceCurvature

Returns the curvature of a surface at a U,V parameter.

SurfaceCurvatureAnalysis

Returns the curvature of a surface.

SurfaceCylinder

Returns the definition of a cylinder surface.

SurfaceDegree

Returns the degree of a surface.

SurfaceDivideAlongCreases

Divides a surface or polysurface into separate parts at kinks or tangents.

SurfaceDomain

Returns the domain of a surface.

SurfaceDraftAnglePoint

Returns the surface draft angle and point at a parameter

SurfaceEditPoints

Returns the edit, or Greville, points of a surface.

SurfaceEvaluate

General purpose surface evaluator.

SurfaceFrame

Returns the plane, or frame, of a surface at a U,V parameter.

SurfaceIsocurveDensity

Returns or changed the isocurve density of a surface or polysurface.

SurfaceKnotCount

Returns the knot count of a surface object.

SurfaceKnots

Returns the knots of a surface object.

SurfaceNormal

Returns the normal to a surface at a U,V parameter.

SurfaceNormalizedParameter

Converts a normalized surface parameter to a surface parameter.

SurfaceParameter

Converts a surface parameter to a normalized surface parameter.

SurfacePointCount

Returns the point count of a surface.

SurfacePoints

Returns the control points of a surface.

SurfacePrincipalCurvature

Adds curvature curves at the evaluated point on a surface.

SurfaceSeam

Changes the seam of a closed surface.

SurfaceSphere

Returns the definition of a sphere surface.

SurfaceSurfaceIntersection

Calculates the intersection of a surface object with another surface object.

SurfaceTorus

Returns the definition of a torus surface.

SurfaceVolume

Calculates the volume of closed surfaces or polysurfaces.

SurfaceVolumeCentroid

Calculates the volume centroid of closed surfaces or polysurfaces.

SurfaceVolumeMoments

Calculates the volume moments of inertia of closed surfaces or polysurfaces.

SurfaceWeights

Returns the weight values assigned to control points of a surface object.

TrimBrep

Trims a surface or polysurface using a surface, polysurface, or plane cutter.

TrimSurface

Removes the portions of the surface outside of the specified interval.

UnrollSurface

Flattens (develops) a surface or polysurface to a planar surface.