ConvertExtrusion

Converts an extrusion object to a surface and polysurface object.

Syntax

Rhino.ConvertExtrusion (strObject [, blnDelete])

Parameters

strObject

Required.  String.  The extrusion object's identifier.

blnDelete

Optional.  Boolean.  Delete the original object.  The default is to not delete the original object (False).

Returns

String

The identifier of the newly created object if successful.

Null

If not successful, or on error.

Example

Dim strObject

strObject = Rhino.GetObject("Select extrusion to convert")

If Rhino.IsExtrusion(strObject) Then

Call Rhino.ConvertExtrusion(strObject, true)

End If

Also See

IsExtrusion