IsExtrusion

Verifies that an object is a lightweight extrusion object.

Syntax

Rhino.IsExtrusion (strObject)

Parameters

strObject

Required.  String.  The object's identifier.

Returns

Boolean

True if successful, otherwise False.

Null

On error.

Example

Dim strObject

strObject = Rhino.GetObject("Select an extrusion")

If Rhino.IsExtrusion(strObject) Then

Rhino.Print "The object is an extrusion."

Else

Rhino.Print "The object is not an extrusion."

End If

Also See

IsBrep

IsNurbsSurface

IsPlaneSurface

IsPolysurface

IsRevSurface

IsSumSurface

IsSurface