DuplicateSurfaceBorder

Creates a curve that duplicates a surface or polysurface border.

Syntax

Rhino.DuplicateSurfaceBorder (strObject [, intType])

Parameters

strObject

Required.  String.  The identifier of the surface or polysurface object.

intType

Optional.  Number.  The border curves to return. The possible values are as follows:

Value

Description

0

Both exterior and interior border curves.

1

Exterior border curves.

2

Interior border curves.

Returns

Array

An array of strings identifying the new curve objects if successful.

Null

If not successful, or on error.

Example

Const rhSurface = 8

Const rhPolysrf = 16

Dim strObject

strObject = Rhino.GetObject("Select surface or polysurface", rhSurface + rhPolysrf)

If Not IsNull(strObject) Then

Rhino.DuplicateSurfaceBorder strObject

End If

Also See

DuplicateEdgeCurves

DuplicateMeshBorder