FilletSurfaces

Create constant radius rolling ball fillets between two surfaces. Note, this function does not trim the original surfaces to the fillets.

Syntax

Rhino.FilletSurfaces (strSurface0, strSurface1, dlbRadius [, arrParam0, arrParam1])

Parameters

strSurface0

Required.  String.  The identifier of the first surface object.

strSurface1

Required.  String.  The identifier of the second surface object.

dlbRadius

Required.  Number.  A positive fillet radius.

arrParam0

Optional.  Array.  A u,v surface parameter of strSurface0 near where the fillet is expected to hit the surface.

arrParam1

Optional.  Array.  A u,v surface parameter of strSurface1 near where the fillet is expected to hit the surface.

Returns

Array

The knot values of the surface if successful.

Null

If not successful, or on error.

Remarks

  arrParam0 and arrParam1 determine the directions of the offsets.  The surfaces will be offset towards the middle of the segment from strSurface0(arrParam0) to strSurface1(arrParam1).

Example

Dim strSurface0, strSurface1

strSurface0 = Rhino.GetObject("First surface", 8)

strSurface1 = Rhino.GetObject("Second surface", 8)

Call Rhino.FilletSurfaces(strSurface0, strSurface1, 2.0)

Also See

IsSurface

FilletSurfacesEx