IsBrep

Verifies an object is a Brep, or a boundary representation model, object.

Syntax

Rhino.IsBrep (strObject)

Parameters

strObject

Required.  String.  The object's identifier.

Returns

Boolean

True if successful, otherwise False.

Null

On error.

Example

Dim strObject

strObject = Rhino.GetObject("Select a Brep")

If Rhino.IsBrep(strObject) Then

Rhino.Print "The object is a Brep."

Else

Rhino.Print "The object is not a Brep."

End If

Also See

IsPolysurface

IsPolysurfaceClosed

IsPolysurfacePlanar

IsSurface