IsPolysurfacePlanar

Verifies a polysurface object is planar.

Syntax

Rhino.IsPolysurfacePlanar (strObject)

Parameters

strObject

Required.  String.  The object's identifier.

Returns

Boolean

True if successful, otherwise False.

Null

On error.

Example

Const rhObjectPolySurface = 16

Dim strObject

strObject = Rhino.GetObject("Select a polysurface", rhObjectPolySurface)

If Rhino.IsPolysurfacePlanar(strObject) Then

Rhino.Print "The polysurface is planar."

Else

Rhino.Print "The polysurface is not planar."

End If

Also See

IsBrep

IsPolysurface

IsPolysurfaceClosed