MakeSurfacePeriodic

Makes an existing surface a periodic NURBS surface.

Syntax

Rhino.MakeSurfacePeriodic (strObject, intDirection [, blnDelete [, blnSmooth]])

Parameters

strObject

Required.  String.  The object's identifier.

intDirection

Required.  Number.  The direction to make periodic, either 0 = U, or 1 = V.

blnDelete

Optional.  Boolean.  Delete input surface.  If omitted, the input surface will not be deleted (False).

blnSmooth

Optional.  Boolean.  Controls kink removal.  If true, smooths any kinks in the surface and moves control points to make a smooth surface.  If false, control point locations are not changed or changed minimally (only one point may move) and only the knot vector is altered.  The default is False.

Returns

String

If blnDelete is False, the identifier of the new object if successful.

String

If blnDelete is True, the identifier of the modified object if successful.

Null

If not successful, or on error.

Example

Const rhObjectSurface = 8

Dim strObject

strObject = Rhino.GetObject("Select a surface", rhObjectSurface)

If Not Rhino.IsSurfacePeriodic(strObject, 0) Then

Rhino.MakeSurfacePeriodic(strObject, 0)

End If

Also See

IsSurfacePeriodic

MakeSurfaceNonPeriodic