IsSurfacePeriodic

Verifies a surface object is periodic in the specified direction.

Syntax

Rhino.IsSurfacePeriodic (strObject, intDirection)

Parameters

strObject

Required.  String.  The object's identifier.

intDirection

Required.  Number.  The direction, either 0 = U, or 1 = V.

Returns

Boolean

True if successful, otherwise False.

Null

On error.

Example

Const rhObjectSurface = 8

Dim strObject

strObject = Rhino.GetObject("Select a surface", rhObjectSurface)

If Rhino.IsSurfacePeriodic(strObject, 0) Then

Rhino.Print "The surface is periodic in the U direction."

Else

Rhino.Print "The surface is not periodic in the U direction."

End If

Also See

IsSurface

IsSurfaceClosed

IsSurfacePlanar

IsSurfaceSingular

IsSurfaceTrimmed