MergeSurfaces

Merges two surfaces into one surface at untrimmed edges. Both surfaces must be untrimmed and share an edge.

Syntax

Rhino.MergeSurfaces (strObject0, strObject1, arrPoint0, arrPoint1, dblRoundness, blnSmooth, dblTolerance, blnDelete])

Parameters

strObject0

Required.  String.  The identifier of the first surface to merge.

strObject1

Required.  String.  The identifier of the second surface to merge.

arrPoint0

Optional.  Array.  2-D pick point on the first surface.

arrPoint1

Optional.  Array.  2-D pick point on the second surface.

dblRoundness

Optional.  Number.  Defines the roundness of the merge.  The default is 1.0 (full smoothing). Acceptable values are between 0.0 (sharp) and 1.0 (smooth).

blnSmooth

Optional.  Boolean.  The surface will be smooth. The default is True. This makes the surface behave better for control point editing, but may alter the shape of both surfaces.

dblTolerance

Optional.  Number.  Surface edges must be within this tolerance for the two surfaces to merge.  If omitted, the document's absolute tolerance is used.

blnDelete

Optional.  Boolean.  Delete input objects after merging.  The default is not to delete objects (False).

Returns

String

The identifier of the merged surface if successful.

Null

If not successful, or on error.

Example

Const rhObjectSurface = 8

Dim strObject0, strObject1

strObject0 = Rhino.GetObject("Select first surface to merge", rhObjectSurface)

strObject1 = Rhino.GetObject("Select second surface to merge", rhObjectSurface)

Call Rhino.MergeSurfaces(strObject0, strObject1)

Also See

JoinSurfaces