OffsetBrep

Offsets a surface or a polysurface by a distance.

Syntax

Rhino.OffsetBrep (strObject, dblDistance [, dblTolerance [, blnBothSides [, blnCreateSolid]]])

Parameters

strObject

Required.  String.  The object's identifier.

dblDistance

Required.  Number.  The distance to offset. This is a signed distance value with respect to face normals and flipped faces.

blnCreateSolid

Optional.  Boolean.  Makes a closed solid from the input and offset surfaces by lofting a ruled surface between all of the matching edges. The default is False.

blnExtend

Optional.  Boolean.  If True, then the function maintains the sharp corners when the original surfaces have sharps corner.  If False, then the function creates fillets at sharp corners in the original surfaces.  The default is True.

dblTolerance

Optional.  Number.  The offset tolerance.

Returns

String

The identifier of the new object if successful.

Array

The identifiers of the new objects if successful, but unable to combine into a single polysurface.

Null

If not successful, or on error.

Example

Const rhObjectSurface = 8

Const rhObjectPolysrf = 16

Dim strObject

strObject = Rhino.GetObject("Select a surface or polysurface", rhObjectSurface + rhObjectPolysrf)

If Not IsNull(strObject) Then

Rhino.OffsetBrep strObject, 10.0

End If

Also See

OffsetSurface