OffsetSurface

Offsets a trimmed or untrimmed surface by a distance. The offset surface will be added to Rhino.

Syntax

Rhino.OffsetSurface (strObject, dblDistance [, dblTolerance [, blnBothSides [, blnCreateSolid]]])

Parameters

strObject

Required.  String.  The object's identifier.

dblDistance

Required.  Number.  The distance to offset.

dblTolerance

Optional.  Number.  The offset tolerance. Use 0.0 to make a loose offset. Otherwise, the document's absolute tolerance is usually sufficient.

blnBothSides

Optional.  Boolean.  Offset to both sides of the input surface. The default is False.

bonCreateSolid

Optional.  Boolean.  Make a solid object. The default is False.

Returns

String

The identifier of the new object if successful.

Null

If not successful, or on error.

Example

Const rhObjectSurface = 8

Dim strObject

strObject = Rhino.GetObject("Select a surface", rhObjectSurface)

If Rhino.IsSurface(strObject) Then

Rhino.OffsetSurface strObject, 10.0

End If

Also See

OffsetCurve