SurfaceKnotCount

Returns the knot count of a surface object.

Syntax

Rhino.SurfaceKnotCount (strObject)

Parameters

strObject

Required.  String.  The object's identifier.

Returns

Array

The number of knots in the U and V directions if successful.

Null

If not successful, or on error.

Example

Dim strObject, arrCount

strObject = Rhino.GetObject("Select a surface")

If Rhino.IsSurface(strObject) Then

arrCount = Rhino.SurfaceKnotCount(strObject)

Rhino.Print "Knot count in U direction: " & CStr(ArrCount(0))

Rhino.Print "Knot count in V direction: " & CStr(ArrCount(1))

End If

Also See

IsSurface

SurfaceKnots