Returns the knots, or knot vector, of a surface object.
Rhino.SurfaceKnots (strObject)
strObject |
Required. String. The object's identifier. |
Array |
The knot values of the surface if successful. |
Null |
If not successful, or on error. |
Dim strObject, arrCount, arrKnots, arrVector
strObject = Rhino.GetObject("Select a surface")
If Rhino.IsSurface(strObject) Then
arrKnots = Rhino.SurfaceKnots(strObject)
If IsArray(arrKnots) Then
arrVector = arrKnots(0)
Rhino.Print "Knot vector in U direction"
For i = 0 To UBound(arrVector)
Rhino.Print "Surface knot value: " & arrVector(i)
Next
arrVector = arrKnots(1)
Rhino.Print "Knot vector in V direction"
For i = 0 To UBound(arrVector)
Rhino.Print "Surface knot value: " & arrVector(i)
Next
End If
End If