IsXformSimilarity

Verifies that a matrix is a similarity transformation. A similarity transformation can be broken into a sequence of dilations, translations, rotations, and reflections.

Syntax

Rhino.IsXformSimilarity (arrXform)

Parameters

arrXform

Required.  Array.  A 4x4 transformation matrix.

Returns

Number

The similarity, where:

Value

Description

-1

This transformation is an orientation preserving similarity

0

This transformation is not a similarity.

1

This transformation is an orientation preserving similarity

Null

On error.

Example

Dim arrXform

arrXform = Rhino.BlockInstanceXform(strObject)

MsgBox Rhino.IsXformSimilarity(arrXform)

Also See

IsXformIdentity

IsXformZero