The following methods are available for creating 4x4 transformation matrices. Rhino matrices act on the left.
Method |
Description |
Verifies that a matrix is the identity transformation. |
|
Verifies that a matrix is the similarity transformation. |
|
Verifies that a matrix is singular. |
|
Verifies that a matrix is the zero transformation. |
|
Creates a change of basis transformation matrix. |
|
Compares two transformation matrices. |
|
Transforms a point from CPlane coordinates to world coordinates. |
|
Returns the determinant of a transformation matrix. |
|
Creates a diagonal transformation matrix. |
|
Creates an identity transformation matrix. |
|
Returns the inverse of a transformation matrix. |
|
Returns the page layout to detail-world transformation. |
|
Creates a mirror transformation matrix. |
|
Multiples two transformation matrices. |
|
Creates a planar projection transformation matrix. |
|
Creates a rotation transformation matrix. |
|
Creates a scale transformation matrix. |
|
Transforms a point from screen coordinates to world coordinates. |
|
Creates a shear transformation matrix. |
|
Creates a translation transformation matrix. |
|
Transforms a point from world coordinates to CPlane coordinates. |
|
Returns the detail-world to page layout transformation. |
|
Transforms a point from world coordinates to screen coordinates. |
|
Creates a zero transformation matrix. |