XformIdentity

Returns the identity transformation matrix.

 

1

0

0

0

0

1

0

0

0

0

1

0

0

0

0

1

Syntax

Rhino.XformIdentity ()

Parameters

None

Returns

Array

The 4x4 transformation matrix.

Example

PrintMatrix Rhino.XformIdentity

Sub PrintMatrix(arrXform)

  For i = 0 To UBound(arrXform, 1)

    str = ""

    For j = 0 To UBound(arrXform, 2)

      str = str & "[" & CStr(arrXform(i,j)) & "] "

    Next

    Rhino.Print str

  Next

End Sub

Also See

XFormDiagonal

XformZero