Returns a diagonal transformation matrix. Diagonal matrices are 3x3 with the bottom row = 0,0,0,1.
d |
0 |
0 |
0 |
0 |
d |
0 |
0 |
0 |
0 |
d |
0 |
0 |
0 |
0 |
1 |
Rhino.XformDiagonal (dblValue)
dblValue |
Required. number. The diagonal value. |
Array |
The 4x4 transformation matrix if successful. |
Null |
If not successful, or on error. |
PrintMatrix Rhino.XformDiagonal(3)
Sub PrintMatrix(arrXform)
For i = 0 To UBound(arrXform, 1)
str = ""
For j = 0 To UBound(arrXform, 2)
str = str & "[" & CStr(arrXform(i,j)) & "] "
Next
Rhino.Print str
Next
End Sub