XformLayoutToWorld

Returns the page layout to detail-world transformation.

Syntax

Rhino.XformLayoutToWorld (strLayout, strDetail)

Parameters

arrPoint

Required. String. The title or identifier of an existing page layout view.

arrPlane

Required. String. The title identifier of an existing detail view in the layout view.

Returns

Array

The 4x4 transformation matrix if successful

Null

If not successful, or on error.

Example

Dim arrPlanePt, arrPlane, arrPoint

arrPoint = Array(0.0, 0.0, 0.0)

arrPlane = Rhino.ViewCPlane

arrPlanePt = Rhino.XformWorldToCPlane(arrPoint, arrPlane)

If IsArray(arrPlanePt) Then

Rhino.Print "CPlane point: " & Rhino.Pt2Str(arrPlanePt, 3)

End If

Also See

XformWorldToLayout